Kodi Dependencies Not Met: What does it mean?

We’ve heard from a lot of our customers that this error message is popping up. Especially when updating add-ons.

So why is this happening? What does it mean?

This is happening because Kodi is continually being updated. As the version of Kodi is updated, the developers for the add-ons must alter their programs so that they’re compatible with the newer versions.

As a result, if you’re running Kodi 15.2 and the add-on you are using has been updated to work with Kodi 16.0, you will see this error message.

Every add-on has details stored in a text file called addon.xml and this tells Kodi what’s required for the add-on to work. When you see this message there’s a good chance the add-on does actually still work just fine (or reasonably well) but the developer hasn’t got around to updating the text file.

This basically means that the same dependencies needed for older versions are not required for newer versions. It DOES NOT always mean that the add-on will not work.

How do I fix this?

The first thing you can do is download the new version of Kodi, either from the Google Play Store on your Element box or from the Kodi web site. If you do not have a fully loaded version of the box with the updater app, you will need to back-up your userdata folder to bring over the add-ons you had loaded.

The second option is simply click the “no” button when that prompt appears that the dependency is not met. This will tell Kodi that you do not want to disable the add-on.

We hope this helps with this sometimes annoying message. Please let us know what you think!

TEAM ELEMENT

Facebook Comments

Website Comments

  1. david white
    Reply

    I have 16.1 and sports devil worked great but now I AM GETTING THE SAME PROBLEMd

Post a comment